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1 General Information 

These operating instructions are intended for the following target group: certified electricians in accordance with DIN VDE 0105 and 
authorised qualified personnel. They explain how to safely and professionally work with the monitoring system. The general safety 
regulations and local accident prevention regulations applicable to the area of use as well as other instructions and safety notices 
must be observed. The operating instructions, especially the section on safety, should be read in full before starting any work on the 
system. 

These operating instructions have been compiled under consideration of the applicable regulations. These operating instructions 
should be kept close to the system at all times and be freely accessible to everyone working with the system.   

All legislation, standards and guidelines of the country in which the system is set up and operated should also be observed. 

The manufacturer provides no guarantees and assumes no liability for damage, or subsequent damage, resulting from: 

• non-intended use 
• unauthorised or improper changes to the system’s connections, settings or programming 
• failure to observe regulations and rules of conduct for safe operations 

Packaging materials are not waste, but valuable materials which should be reused or recycled. 

Batteries and electronic components contain materials, which will cause harm to human health and the environment if not properly 
disposed of. National guidelines and regulations for correctly disposing of used batteries and electronic components should be 
observed! 
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2 Introduction 

 

The Wireless Professional WLZent is an industrial PC with touch display, integrated power supply and Wireless Professional USB 
coordinator, as well as a USB and network socket accessible from the exterior. A Linux operating system, a VNC viewer, remote access 
software and the Wireless Professional software are installed on the industrial PC. 

The Wireless Professional WLZent is intended for use as a central testing device in the Wireless Professional system. The device can be 
operated using the touch display. The WLZent satisfies the requirements of an automatic test system in accordance with EN 62034. 

 
Note: This documentation is stored on the device at /home/rp/Desktop/manual/. 
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3 Technical Data 

  
Processor chip set ARM Cortex-A72 quad  
Processor clock speed 1.5 GHz 
RAM 4GB SDRAM 
LAN Gigabit Ethernet 
Power consumption Max. 17W, PF 0.52 
Protection Protection class 1 
Dimensions H 225mm x W 295mm x D 75mm including wall bracket 
Type of mounting Wall mounting 
Ambient temperature 15 °C to 30°C 
Weight 4 kg 
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4 Structure 

 

 

Figure 1 View of WLZent from left  

 

 

Figure 2 View of WLZent from right 
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Figure 3 WLZent internal components  

1 Wireless coordinator 9 Optional cable entry point on side with strain relief  
Or blanking plug 

2 Power supply 10 Indicator window for coordinator 
3 Mains supply terminal 11 Indicator window for WLZent processor board 
4 Internal strain relief 12 Casing lock 
5 Junction box 13 Network socket 
6 WLZent processor board with  

SD card 
14 USB socket 

7 Knurled nut with oval washer 15 Touch display 
8 RTC board 16 Second cable entry on the side, e.g. for fault indication 

contact 
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5 Assembly Instructions for Wireless Professional WLZent 

The Wireless Professional WLZent is a device intended to be mounted on the wall. 
For ergonomic reasons, we would recommend mounting at a height of 1.40m (± 0.20m) (centre of screen). 
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Ensure it is adequately secured. 
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Once the device has been mounted, remove the protective film from the display. 

To power the device from the optional socket on the side or for a fault indication contact, remove the blanking plug and replace with 
the cable bushing provided (see page 8). 
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6 Operating the Wireless Professional WLZent 

The Wireless Professional WLZent is operated using a  touch display (15) . The touch display can be operated directly using a finger or 
a pen suitable for capacitive touch displays. 

An on-screen keyboard can be used to enter text.  

6.1 Touch operation 
A tap on the touch display is the same as a left-click with a conventional mouse. Desktop icons are simply tapped to launch the 
programs indicated on them. No double-clicks are required in the operating system. 

 

Drawing your finger from one point to another highlights an area. This is the same as the highlight function offered by a conventional 
mouse.  

To perform a right-click, the touch screen has to be tapped using 2 fingers at the same time. If there is a context menu available for the 
icon, this is how to open it. The context menu opens near the finger which was first registered by the touch. 

 

 

Figure 4 Wireless Professional WLZent context menu 
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To use the drag and drop function, start by tapping on an object. It can then be moved by tapping on it and dragging it. 

 

If 3 fingers are placed on the touch display and dragged down, the window in the foreground is minimised in the taskbar 

 

If a window has a scroll bar, the window can be scrolled through by placing 2 fingers on the touch display and moving them to the 
side or up/down.  
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6.2 The on-screen keyboard 
The on-screen keyboard can be called up via the icon in the taskbar or the Start menu.  

If a window with an input box is opened in the Wireless Professional, to enter a password for example, or if the user clicks in a text box, 
the on-screen keyboard is opened automatically. 

If the icon in the taskbar is tapped on, a context menu opens, and the user has to select “Show Onboard” for the keyboard to be 
displayed. 

 

Figure 5: Onboard context menu 

 

 

 

 

 

 

 

 

 

 

If the on-screen keyboard is to be opened via the Start menu, the user will need to go to Start menu->Universal Access ->Onboard. 
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Figure 6 Onboard Start menu 

 

Figure 7 Wireless Professional WLZent on-screen keyboard 

The keyboard has a DE German layout and does not have a numerical pad in the first view.  
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The view can be switched using the “123” button. The function keys are then displayed. 

 

Figure 8 Wireless Professional WLZent on-screen keyboard function keys 

Tapping the “123” button again or tapping the “Esc” button takes you back to the previous view. 

The directional button  located above the “Abc” button is used to move the keyboard on the screen. This may be necessary if text 
input boxes are covered by the keyboard. 

The “x” button above the directional button closes the on-screen keyboard. 

6.3 Using a USB stick for storage on the Wireless Professional WLZent 
USB sticks formatted in FAT format, USB card readers or input devices can be used on the USB socket (14) . Building plans can thereby 
be transferred to the WLZent, as can data from older WLZent/WLTouch systems or CPCs. 

! Warning: Before being removed, USB sticks should always first be ejected (deactivated) by the software, otherwise data 
may be lost. 

The USB stick has to be ejected by the software by means of a taskbar symbol or using the file manager installed on the Wireless 
Professional WLZent. 
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6.3.1 Ejecting via taskbar symbol 
Clicking on the taskbar symbol opens a context menu, which lists all the storage media currently connected.  

 

Figure 9 Ejecting storage medium 

The eject symbol (red circle) is displayed after the name of the storage medium. To eject the medium, click on the eject symbol.  
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6.3.2 Storing building plans on the WLZent 
The “Facility” folder is provided in the WirelessProfessional WLZent storage system for storing building plans. The “Facility” folder is 
located on the backup USB stick. 

Building plans can be copied directly to the WLZent from a connected USB storage medium into the “Facility” folder. Alternatively, the 
WLZent can be shut down and the backup USB stick connected to a computer in order to copy the building plans to the backup USB 
stick. 

Storing building plans outside the designated storage location can impair the functionality of the WirelessProfessional WLZent, as this 
unnecessarily occupies working memory. This can result in the WirelessProfessional software lacking the necessary working resources.   
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6.4 Meaning of signals in indicator windows 
Status LEDs can be seen in the two indicator windows (10 & 11) on the left and right under the screen. These provide information about 
the current status of the Wireless Professional WLZent and Wireless Professional coordinator.  

The coordinator’s 3 signal LEDs are displayed in the coordinator indicator windows (10). 

Colour Status Meaning 
Green Flashing The Wireless Professional software is not running 
Green On The Wireless Professional software has been started and is communicating with the device 
Blue Flashing Wireless traffic indicator 
Red On There is an error in the Wireless Professional system 

 

3 signal LEDs are displayed in the WLZent indicator window (11). These provide information about the operating status of the WLZent 
processor board (6). 

Colour Status Meaning 
Green On The WLZent processor board is being powered 
Blue On Device connected with the cloud 
Orange On The backup USB stick is being accessed (read/write access) 
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7 Tamper-Proof Operating System 

The Wireless Professional WLZent is equipped with an operating system, which runs in read-only mode as standard.  

This means that any changes to the operating system are lost after a reboot. 

To make permanent changes to the operating system, it must be switched to read-write mode.  

Different icons are shown on the desktop to indicate which mode the operating system is running in at the present time. 

Mode Desktop symbol Meaning 
Read-only 

 

Changes to the operating 
system are lost following a 
reboot 

Read-write 

 

Changes to the operating 
system are permanent 

 

Note: Only one of the two icons is displayed at any one time. 

Examples of permanent changes to the operating system include changes to the user password.  

If a change is only possible in read-write mode, the operating system provides information to this effect and switches automatically 
into this mode. Once the change has been made, read-write mode is exited automatically.  

Switching between read-write and read-only modes serves to protect the system’s security of operation and protects it from being 
tampered with. 
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8 Maintenance Mode 

In Maintenance mode, permanent settings can be configured on the operating system, such as connecting to a WLAN network. 

Note: Maintenance mode should only be used by trained qualified personnel. An operating error in Maintenance mode may result in 
the Wireless Professional WLZent ceasing to function properly. 

8.1 Launching Maintenance mode 
Maintenance mode is launched via the Start menu by selecting “Maintenance Mode” under “Other”. 

Start menu->Other->Maintenance Mode 

 

Figure 10 Launching Maintenance mode 

Once this has been done, it will take around 15 seconds for the WLZent to start to perform a reboot. The remote connection may be 
lost during this time. 

As soon as the WLZent has powered back up again, the WLZent operating system will be in read-write mode (see Chapter 7). 
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Figure 11 Desktop in Maintenance mode 

The Wireless Professional software is not started in Maintenance mode. Various scripts are also provided on the desktop in 
Maintenance mode. 

 

8.2 Exiting Maintenance mode 
Maintenance mode can only be exited via the “ExitMaintenanceMode” script on the desktop. If a reboot is performed as described in 
Section 9.4 or the device is shut down as described in Section 9.5, the Wireless Professional WLZent reboots in Maintenance mode. 

Maintenance mode should be exited by double-clicking on the “ExitMaintenanceMode” link on the desktop.  
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Figure 12 exit maintenance mode 

Once this has been done, the “Execute file” window is reopened. The “Execute in Terminal” button should be selected. The Wireless 
Professional WLZent now performs a reboot of its own accord.  

Once this button has been clicked on, it will take around 20 to 30 seconds before the Wireless Professional WLZent performs a reboot 
triggered by the script. After the reboot, the WLZent will again be in read-only mode and the Wireless Professional software is restarted. 
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9 Commissioning the Wireless Professional WLZent 

9.1 Switching on for the first time 
The Wireless Professional WLZent can be connected directly to the sub-distribution using a permanent 3-wire connection cable or to a 
socket using the mains connection cable supplied. Lead the cable into the WLZent housing and connect the cable inside the electrical 
connection (5) box on the 3-pin terminal connector (3). Close the electrical connection box afterwards (see chapter 5).  

 

Warning: The cable should be guided through one of the strain reliefs provided (4, 9). 

As soon as the Wireless Professional WLZent has been supplied with power, the Wireless Professional WLZent boots up and 
automatically starts the Wireless Professional software.  

You can see that the Wireless Professional WLZent is active from the fact that the green LED lights up permanently in the right-hand 
indicator window (11). As soon as the Wireless Professional software has been started, the green LED in the left-hand indicator window 
(10) also lights up permanently. 

The device is now operational, and the Wireless Professional software interface appears in full-screen mode on the touch display. 

 

Figure 13 Wireless Professional software in full-screen mode 

The wireless professional system must be commissioned in accordance with the software manual.  

 
Important!: Commissioning must be completed by restarting the Wireless Professional WLZENT03, see section 9.4 
Rebooting the Wireless Professional WLZent. We also recommend carrying out a manual backup to an external storage 
medium after commissioning. 
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9.2 How the WLZent responds to a power supply failure  
The Wireless Professional WLZent does not have a battery to maintain operation should the power supply to the Wireless Professional 
WLZent fail. The Wireless Professional WLZent is therefore switched off. The monitoring functions, control options and automatic 
checks are also not active in such cases. 

9.3 How the WLZent responds to power being restored 
When power is restored, the Wireless Professional WLZent is rebooted, and the Wireless Professional software starts automatically. 
There is no need to boot the Wireless Professional WLZent manually.  

9.4 Rebooting the Wireless Professional WLZent 
Should you need to reboot the Wireless Professional WLZent, you can do this via both the software and hardware. 

9.4.1 Software restart 
The operating system of the Wireless Professional WLZent can be rebooted via the graphic interface. To reboot, go to Start menu-
>Other->Reboot.  

Warning: The Wireless Professional software should be closed before rebooting to avoid data being lost.  
This point is no longer relevant if using Wireless Professional version 3.0 or higher.  

 

Figure 14 Wireless Professional WLZent Start menu Oher Reboot 

If the Start menu is not displayed (see Figure 9), the Wireless Professional software runs in full-screen mode. The Alt + Enter key 
combination or the Help menu in the top right can be used to switch between full-screen mode and the Wireless Professional software’s 
window mode. 

Warning: a password has to be entered in order to exit full-screen mode.  
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9.4.2 Hardware reboot 
Should you not be able to reboot the operating system, you can also perform a hard reset. This is done by pressing the Reset button. 
The Reset button is not accessible if the casing is closed. The casing must be opened in order to press the Reset button. 

 

Figure 15 Position of the Reset button 

 

9.5 Switching off the Wireless Professional WLZent 
To ensure that no data is lost when switching off the Wireless Professional WLZent, the operating system must be shut down correctly.  

Before powering down, data from the Wireless Professional software should be backed up by pressing the “Save System Data” button 
or by closing the Wireless Professional software. This step is not necessary with Wireless Professional software version 3.0 and higher. 
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Figure 16 WLZent Start menu Other Shutdown 

The device is shut down by going to Start menu->Other->Shutdown. This closes the Wireless Professional software, and the last version 
of the data is transferred to the backup USB stick. 5 seconds after the green LED in the indicator window for WLZent processor board 
(11) has gone out, the Wireless Professional WLZent can be disconnected from the power supply. 
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10 Setting Date and Time 

Upon delivery, the date and time are set to the time zone “Berlin, Paris, etc… (GMT+2)”. The real time clock used with battery buffer 
allows the time to continue to run even if there is a power cut or the WLZent is switched off.  

There are no means of setting the date and time manually. 

If the time or date displayed by the WLZent differs from the actual time, the WLZent must be connected to the Internet. Once a 
connection to the Internet has been established, it will take around 1 minute for the WLZent to automatically receive the date and time 
from the online time server. 

After the WLZent has been rebooted, you can tell that the RTC battery is flat because a modification to the time is documented in the 
Wireless Professional log file once the application is launched.  

If this happens, the WLZent’s RTC battery should be changed.  

The steps required to change the battery can be found in the maintenance schedule. This is stored as a PDF document in the folder 

 /home/rp/Desktop/manual/Wartungsplan_WLProfessional.pdf. 

Once the WLZent’s RTC battery has been changed, the WLZent must be connected to the Internet for the internal clock to be reset 
correctly. 
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11 Screensaver 

There is a screensaver program installed on the Wireless Professional WLZent. The screensaver is initial configured so that the 
background lighting of the touch display (15) is deactivated if the user hasn’t entered anything on the device for 2 minutes. 

If the user enters something via the touch display (15) the background lighting for the touch display (15) is reactivated. Inputs via an 
input device connected to the USB-Port (14) or an input device connected via Bluetooth do not switch the backlight back on. 

Screensaver settings can be changed using WLX Settings Tool see 13.1.1  Screensaver Settings. 

The signal LEDs displayed in the status indicator areas (10, 11) remain active even if the screen saver is active.  
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12 Setting Background Lighting 

The brightness of the touch display’s background lighting is set to 50% of max. brightness upon delivery. If necessary, the background 
lighting’s brightness can be increased or decreased. 

To set the background lighting brightness, go to Start menu->Other->Background Light Control.  

 

Figure 17 WLZent Start menu Other Background Light Control 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 
 
 
 
 

Wireless Professional WLZent 
 Operating Instructions 

Page 31/98  

The “Configurations” window opens.  

 

Figure 18 "Configurations” screen brightness 

The level of background lighting brightness currently set is displayed as a percentage. The button to the left of the percentage figure 
reduces the brightness by 10%. The button to the right of the percentage figure increases the brightness by 10%. To apply the value 
set, close the window using the “Close” button. 
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13 WLX Settings Tool 

The WLX Settings Tool is used to configurate the WLZent. 

The WLX Settings Tool is only available during maintenance Mode and can be started by start menu->Other->WLX Settings. 

 

Figure 19 WLX Settings Tool in the start menu. 

The WLX Settings Tool is a comfortable option to change the settings on some components of the WLZent.  



 
 
 
 
 
 

Wireless Professional WLZent 
 Operating Instructions 

Page 33/98  

 

Figure 20 WLX Settings Tool 

13.1.1  Screensaver Settings 
The settings for the screen saver can be modified with the menu item.  

 

Figure 21 WLC Settings Tool: Screen saver settings. 
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With the textbox „new value in minutes:“ it is possible to set a new time until the backlight of the display turned off. The new value will 
be saved be tapping the bottom “ok”.  

13.1.2  Firewall Settings 
This menu item starts the Firewall settings.  

 

Figure 22 WLC Settings Tool: start Firewall Settings  

By tapping the button „OK“, the user password request window will be opened. The user password is taken of the Info.txt from the 
desktop.  
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Figure 23 WLC Settings Tool: User Authentication for firewall settings. 

After successfully authentication the „Firewall“ window is shown on the display. 

 

Figure 24 Firewall settings 
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13.1.3  Change User Password 
The user password can be changed with the menu item.  

 

Figure 25 WLC Settings Tool: User Password change.  

The current user password must be written into the textbox „current Password:“. 

Enter the new password into the two boxes labeled „new Password:“.  

By tapping the bottom „ok” the new password will be saved.  
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Figure 26 WLC Settings Tool: User password change done. 

Is the new password successfully saved, a “done” will be showed into the „WLX Settings Tool“ window. 

Note: password changed need to be documented properly.  
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14 Network Configuration 

The Wireless Professional WLZent has an RJ-45 socket (LAN connection) (13), which can be accessed externally, as well as a WLAN 
interface, which can be used to integrate the Wireless Professional WLZent into a network.  

Note: If both the Ethernet socket and the WLAN interface are being used, Internet access for the WLZent must be provided via the 
Ethernet socket.  

14.1 Connecting with a cable network 
The Wireless Professional WLZent is set to DHCP upon delivery. As soon as a network cable with a DHCP server is plugged in, the WLZent 
is automatically assigned an IP address.  

 

Figure 27 Taskbar with connected Ethernet 

Once a connection has been established, this is indicated in the taskbar by means of the Up/Down arrow. 

If there is no connection to a cable network, the Up/Down arrow is displayed with a red cross over it. 

 

 

Figure 28 Taskbar with no connected Ethernet 

Note: If the WLZent is connected to a WLAN network at the same time, the arrow symbol is not shown. 

14.1.1 Static IP address  
To issue a static IP address, the network settings must be called up from the Start menu by going to “Start menu->Sonstige->Netzwerk 
Einstellungen”. 

Note: If a static IP address is to be permanently issued, it must be entered in Maintenance mode. (see Chapter 8 Maintenance Mode) 

Note: The procedure for setting a static IP address for the WLAN interface is identical to that for the LAN interface; “wlan0” simply has 
to be selected in place of “eth0”. 
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Figure 29 Network settings in the start menu 

The “Network Preferences” window then opens. 

 

Figure 30 Network Preferences 
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The interface for which a static IP is being set is selected from the drop-down box to the right of the drop-down box containing the word 
“interface”. The drop-down box is tapped on and the “eth0” interface (wired network, RJ45 socket) is there by selected.  

 

Figure 31 Network preferences for eth0 

Note: There are limitations on selecting a different interface via the WLZent touch display which is why we recommend using the arrow 
keys on the on-screen keyboard to select an interface.  

Once the interface has been selected, the boxes have to be completed. Tapping in a text box automatically opens the on-screen 
keyboard. 
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Figure 32 static IP address for eth0 

 

Box name Meaning 
IPv4 Address 4-byte IP address  
IPv6 Address 6-byte IP address 
Router IP address of the router/gateway 
DNS Servers IP address of the domain name 

server 
DNS Search Domain of a name server 

 

The IP address is entered as shown in the example also, the address of the router/gateway and a DNS (Domain Name Server).  

The subnet mask is set to 255.255.255.0 as standard.  

A sub-mask suffix can be entered after the IP address if needed. 

The box for the DNS Search can be left empty if a DNS server is specified. 

If no IPv6 is assigned, a tick should be placed in the “Disable IPv6” checkbox. 

The “Automatically configure empty options” checkbox must not be selected. 

Note: Instances may arise where the static IP address is only applied by the network adapter once the network cable has been 
disconnected and plugged back in again.  

Once the corresponding boxes are completed, the settings are applied by clicking on the “Apply” button. The window can then be 
closed by clicking on the “Close” button. 
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14.2 Connecting to a wireless network   
When the Wireless Professional WLZent is delivered, the WLAN interface is enabled. For the connection data to be permanently 
stored in the WLZent, the WLZent must be switched to Maintenance mode (see Section 8). Any wireless networks in range are 
displayed when the arrow symbol in the taskbar is tapped. 

 

Figure 33 Available WLAN networks. 

Tap on the wireless network that is to be connected to the WLZent. If the network is encrypted, a window with the name of the 
selected wireless network as its title opens.  
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Figure 34 Entering WLAN code 

The network code for the wireless network must be entered and confirmed with OK. 

 

Figure 35 WLZent with connected WLAN 

Once the connection has been successfully established, the arrow symbol disappears from the taskbar and is replaced with another. 
The Wireless Professional WLZent is now connected to the wireless network. 

Maintenance mode should now be exited. After the reboot, the Wireless Professional WLZent is connected to the wireless network. 
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Displaying connection information 

Tap on the arrow symbol to find the IP address issued by the DHCP server. A context menu containing all WLAN networks within range 
opens. Around 2 seconds later, a window appears in front of the WLAN networks. This contains the IP addresses of the network 
interfaces. In this case, the IP address of the Ethernet socket is 10.0.144.14 

 

Figure 36 WLZent connection information  
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15 Bluetooth 

The Wireless Professional WLZent has a Bluetooth interface, which can be used to wirelessly connect input devices, such as 
keyboards, to the WLZent. The Bluetooth interface is not enabled upon delivery.  

For a permanent connection, the Wireless Professional WLZent must be switched to Maintenance mode (see Section 8) 

15.1 Enabling Bluetooth 
To enable the Bluetooth interface, tap on the Bluetooth symbol in the taskbar. 

 

Figure 37 Enabling Bluetooth 

The context menu for enabling the Bluetooth interface appears. Tap on the “Turn On Bluetooth” button. 

 

Figure 38 Bluetooth taskbar enabled 

When the Bluetooth interface has been enabled, the Bluetooth symbol is displayed in blue. 
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15.2 Disabling Bluetooth 
If the Bluetooth interface is to be disabled, tap on the Bluetooth symbol in the taskbar. 

 

Figure 39 Disabling Bluetooth 

The context menu appears, tap on the “Turn Off Bluetooth” button. 

When the Bluetooth interface has been disabled, the Bluetooth symbol is again displayed as shown in Figure 37 Enabling Bluetooth 

15.3 Pairing a device via Bluetooth 
To pair a Bluetooth device with the Wireless Professional WLZent, the Bluetooth interface on the WLZent must be enabled. Once this 
has been done, tap on the Bluetooth symbol in the taskbar and in the context menu, tap on “Add Device…” (see Figure 39 Disabling 
Bluetooth). 

The “Add New Device” window opens and shows all devices within range and in pairing mode.  
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Figure 40 Bluetooth keyboard within range 

In this example, there is a Bluetooth keyboard within range. Tap on the desired device. The “Pair” button then appears. Tap on this 
button to pair the devices. 

Follow the instructions on the WLZent touch display.  
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Figure 41 Verification code 

This is shown when devices have been successfully paired. 

 

Figure 42 Pairing successful 
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Tapping on the Bluetooth symbol in the taskbar adds the paired device to the list in the context menu. 

 

Figure 43 WLZent with paired Bluetooth device 
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15.4 Disconnecting a paired device 
If a device paired with the Wireless Professional WLZent via Bluetooth is to be disconnected, tap on the Bluetooth symbol in the 
taskbar. Tap on the Bluetooth device in question in the context menu  

 

Figure 44 Disconnecting/removing WLZent Bluetooth device 

The “Disconnect…” button disconnects the Bluetooth device from the WLZent. The WLZent does however retain the connection 
information, meaning that it can be connected again without having to access Pairing mode. 

The “Remove…” button disconnects the Bluetooth device from the WLZent. The connection data is deleted in this instance. If the 
device is to be connected again at a later date, it will have to be paired again. 
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16 Remote Access via RustDesk  

The RustDesk remote access software is installed on the Wireless Professional WLZent.  

16.1 Establishing connection 
In order for a remote connection via RustDesk to be established, the Wireless Professional WLZent must be connected to the Internet. 

RustDesk should be started on the device with which the connection to the WLZent is to be established. 

 

Figure 45 RustDesk surface 

 

The RustDesk ID is unique to each WLZent and is noted on the accompanying WLZent info sheet along with the password. 
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Figure 46 Info sheet 

 

Figure 47 RustDesk with connection data 
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After entering the ID, click on the “Connect” button. The connection to the WLZent is then established. You are asked to enter the 
password 

 

Figure 48 RustDesk password input 

Once this has been entered, the WLZent's display is shown. 

 

Figure 49 RustDesk remote connection 
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16.2 Terminating connection 
To terminate the remote connection, the RustDesk window should be closed. 

 

Figure 50 Disconnect RustDesk connection 

RustDesk notes the last connections used so that the ID does not have to be entered again for the next session. 

 

Figure 51  RustDesk window with last used connections  
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16.3 Changing RustDesk connection password 
The RustDesk connection password for the WLZent cannot be changed. 

16.4 RustDesk connections from the WLZent to other devices 
If a RustDesk remote connection is to be established from the WLZent to another device, please note that RustDesk must not be put 
into full-screen mode because there is no way of exiting this option without connecting an external mouse. 

  



 
 
 
 
 
 

Wireless Professional WLZent 
 Operating Instructions 

 Page 56/98  

17 VNC Remote Connection  

Just like WLTouch, the Wireless Professional WLZent is able to monitor one or more Wireless Professional control centres (WLTouch, 
WLCPC or WLZent) located in the local network and to control them using remote access. Instances may arise where the VNC Viewer is 
changed when the WLZent is updated. 

17.1 VNC Viewer 
There is a VNC Viewer installed on the WLZent. This can be launched by going to Start menu->Internet->VNC Viewer. The Wireless 
Professional software can also launch the VNC Viewer. 

 

Figure 52 Wireless Professional WLZent Start menu Internet 
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The “RealVNC Viewer” window opens. 

 

Figure 53 Remote desktop viewer  

  



 
 
 
 
 
 

Wireless Professional WLZent 
 Operating Instructions 

 Page 58/98  

17.1.1 Establishing VNC connection to a device 
To establish a VNC connection, the IP address of the connection destination is entered in the text box and confirmed with Enter.  

  

Figure 54 Remote desktop viewer window, Connect window 

Note: A port may have to be specified along with the IP address. With Wireless Professional version 2.4 and higher, VNC port 5900 is 
used. Port 5901 must be used with older devices. To do this, the port, e.g. 10.3.141.1:5901, must be written after the IP address. 

As soon as the address has been confirmed by clicking on “Enter”, the connection is established. 

 

Figure 55 VNC Connection setup 
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When the VNC Viewer is run on the device for the first time, the message is displayed via an unencrypted connection. The VNC 
connection password is transferred securely.  

 

 

 Figure 56 VNC Connection encryption 

If the “Continue” button is clicked on, the input window for the VNC connection password opens. 

 

Figure 57 VNC password input 

The VNC connection password can be found in the accompanying info sheet. 

Once the password has been entered correctly and confirmed by clicking on the “OK” button, the destination device’s monitor is 
displayed. 
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Figure 58 Remote desktop viewer window with enabled connection 

17.1.2 Terminating VNC connection to a device 
The VNC connection is terminated by tapping on the “x” button in the top right. This does not close the VNC Viewer. 

17.1.3 Closing VNC Viewer 
To close the VNC Viewer, the session window and the actual VNC Viewer window need to be closed. Both windows are closed using the 
“x” in the top right corner. 
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17.1.4 Scaling view 
Screen scaling is enabled as standard. However, this may cause problems when using the touch display. To cancel screen scaling or 
to re-enable it, the on-screen keyboard must be displayed, and its view switched to include the function keys (see Section 6.2) 

 

Figure 59 Scaling view 

A context menu is opened by pressing the “F8” function key. The tick next to “Automatic scaling” should be removed by tapping on it. 
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Figure 60 VNC session window 

The VNC session window with scroll bars is then displayed. 

To re-enable scaling, the tick next to “Automatic scaling” must be selected again. 

 

17.2 VNC-Server  
For security reasons, there is no VNC Server available on the Wireless Professional WLZent.  
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18 Moving Systems onto the WLZent  

In order for data to be imported to the Wireless Professional WLZent without any version issues, the version of the Wireless Professional 
software on the WLZent must be the same as or higher than the version from where the data originates. 

18.1 Moving Wireless Professional from CPC to WLZent 

18.1.1 CPC with Wireless Professional version 2.4 and newer 
If working with a CPC with Wireless Professional software version 2.4 or newer, the CPC should be shut down and then disconnected 
from the power supply. 

The backup USB stick should be removed from the CPC. The backup USB stick should be inserted into the WLZent.  

The WLZent should be connected to the power supply. When powered up, the data is automatically loaded from the backup USB stick. 
Once powered up, the Wireless Professional software is available as usual.  

18.1.2 CPC with Wireless Professional version 2.2 and older 
If the Wireless Professional system is to move from a Wireless Professional CPC to a Wireless Professional WLZent, the following are 
needed: 

• USB card reader 
• CPC3 transfer script (https://rptechnik.freshdesk.com/de/support/home) 
• FTP and remote connection on “old” CPC 
• Remote connection on CPC 

18.1.2.1 Preparing the CPC3 for the move 

18.1.2.1.1 Copying script 
The “CPC3_prepare_transfer.sh” script must be copied to the CPC and run there. A file transfer connection, e.g. using WinSCP, must 
be established in order to transfer the script.  

 

Figure 61 File transfer to CPC1/2 

 



 
 
 
 
 
 

Wireless Professional WLZent 
 Operating Instructions 

 Page 64/98  

The “CPC3_prepare_transfer.sh” script is copied directly into the root directory of the CPC. 

Note: A backup copy of the “wireless” folder should also be produced. 

Warning: Log files (system, communication & inspection) are not included in the transfer. 

Once the script has been copied onto the CPC, a remote connection with the CPC should be established.  

18.1.2.1.2 Running script 
Once the remote connection has been established, the Wireless Professional software should be closed and the LXTerminal launched 

 

Figure 62 Start terminal on CPC1/2 

The ‘chmod + x CPC3_prepare_transfer.sh’ command should be entered in the terminal window and confirmed with Enter.  
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Figure 63 Make CPC1/2 transfer script executable. 

The command has been run when the terminal prompt sh-4.4# appears again. 

Then the script must be run by entering the  
command ‘./ CPC3_prepare_transfer.sh’ and confirming with Enter 

 

Figure 64 CPC1/2 execute transfer script. 

After around 5 seconds, the script will have been run and the CPC can be shut down. 
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Figure 65 CPC1/2 Shut down CPC1/2 

Once the device has been shut down, it can be disconnected from the power supply. The SD card is removed from the device.  The SD 
card is still needed. 

18.1.3 Transferring data to CPC3 
The WLZent should be started by connecting to the power supply. Once the WLZent has been powered up, it is switched into 
Maintenance mode (see Section 8.1). 

The SD card of the CPC is now inserted into the USB card reader and plugged into the WLZent.  

As soon as the operating system has recognised the SD card, the “Wechseldatenträger” window is displayed twice. This is correct 
behaviour because the SD card has 2 partitions. 

 

Figure 66 WLZent3 Desktop after connecting the USB card reader. 
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The two “Wechseldatenträger” windows are closed by clicking on the “Abbrechen” button. 

The “CPCupgrade” script is now run by tapping on the desktop link twice. 

 

Figure 67 WLZent import script of CPC1/2 data. 

The “Datei ausführen” window is opened. The “im Terminal ausführen” button in this window should be selected. 

 

Figure 68 Execute WLZent Script  

 

Once the button has been clicked on, the “CPC3 copy and upgrade” window opens. 
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Figure 69 WLZent Copy and Upgrade window 

The partition on the SD card containing the root directory of the CPC must be selected from the drop-down list of the “Path to old root 
partition on SD Card” box.  

 

Figure 70 WLZent Copy and Upgrade window: Select Partition 

The first partition is typically 100MB in size and the second 6.9GB. The root directory is in the 6.9GB partition. Select this. Once the 
right partition has been selected, the import process is started by clicking on the “copy” button.  

As soon as the process is complete, the “—Task Done –” message appears.  
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Figure 71 WLZent Copy and Upgrade window: import successful. 

Should an error have occurred during the import, “—Error –” appears. 

After the import, the “CPC3 copy and upgrade” window is closed by clicking on the “x” in the top right.  

The SD card is now ejected (see Section 6.3). 

Once the SD card reader has been ejected, Maintenance mode should be exited (see Section 8.2). Once the WLZent has been fully 
rebooted, the data is transferred into the Wireless Professional software. 

Note: The coordinator’s serial port has to be selected again because it will have a different name on the CPC3 to that on the “old” 
CPC3. 

Note: If the coordinator is also to be changed along with the CPC3, once the data has been imported, the coordinator will have to be 
changed as described in the Wireless Professional manual in order to establish the wireless connection between the devices and new 
coordinator. 

18.2 Import data from WLZentx/WLTouchx 
 To transfer data to the Wireless Professional WLZent3, a USB stick formatted in FAT32 format is required. 

18.2.1  Preparing WLZent1/WLZent2 for the migration  
The USB stick is plugged into the WLZent1/2. If the Wireless Professional software is currently active, the user must close it. 

The file explorer is opened via the “WLZent” desktop icon. 
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Figure 72 WLZent1/2 Desktop 

The folder “wireless” is selected and copied to the clipboard via the menu bar “Edit->copy”, the key combination “Ctrl + c” or by 
right-clicking and selecting the context menu item “Copy”.

 

Figure 73 WLZent1/2 File explorer 

Then the inserted USB stick, in this example the USB stick is called FATSTICK, is selected by clicking on it. 

The “wireless” folder is now copied to the USB stick using the “Edit->Paste” menu bar. 

After the copying process is complete, the USB stick is ejected using the symbol behind the name. 

Caution: if the USB stick is removed immediately, data may be lost. 

Note: the folder must not be renamed or placed in a subfolder, otherwise the data import will not work. 
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18.2.2  Preparing WLTouch for the migration 
The USB stick is plugged into the WLTouch. If the Wireless Professional software is currently active, the user must close it. 

The file explorer is opened and the c:\ drive is selected. 

The "WirelessProfessional" folder is selected on the drive and copied to the clipboard using the key combination "Ctrl + C", the menu 
bar item "Edit->Copy" or by right-clicking and the context menu item "Copy". 

The USB stick is then selected and the "WirelessProfessional" folder is copied to the USB stick using the menu bar item "Edit->Paste". 

After the copying process is complete, right-click on the USB stick and select the menu item "Eject". The USB stick can then be 
removed from the device. 

Caution: if the USB stick is removed immediately, data loss may occur. 

Note: the folder must not be renamed or placed in a subfolder, otherwise the data import will not work. 

18.2.3 Transferring data to the WLZent3 
 The WLZent3 is started by connecting it to the power supply. 

After the boot process switch to maintenance mode as descript in section 8.1 Launching Maintenance mode. 

As soon as the WLZent3 has booted up again, the USB stick is plugged into the USB Port (14) of the WLZent. 

As soon as the operating system has recognized the USB stick, the “Removable Disk” window is displayed. 

 

Figure 74 WLZent USB drive recognized. 

The "Removable Disk" window is closed by clicking on the "Cancel" button. 

The "WLTouchUpgrade" script is used to import the data of a WLTouch to the WLZent3. The "WLZentUpgrade" script is used to import 
the data of a WLZent1/2 to the WLZent3. The corresponding script is executed by double-clicking the desktop shortcut. 
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Figure 75 WLZent: Scripts for importing WLZent1/2 or WLTouchX data. 

The import is explained below using WLZent1/2 data. The steps are identical for importing data from a WLTouch. 

The "Run file" window opens. In this window, select the "Run in terminal" button. 

 

Figure 76 Execute WLZent Script  

After clicking the button, the “WLZent copy and upgrade to CPC3” window opens. 
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Figure 77 Copy and upgrade window 

In the dropdown list of the “Path to Wireless Folder on Flash Drive” field, select the USB stick on which the “wireless” folder is located. 

Once the USB stick is selected, the import process is started using the “copy” button. 

Once the process is complete, the message “—Done—” is displayed.  

 

Figure 78 Data import successfully completed. 

If there is an error during import, "—Error -" is displayed instead. 

The "WLZEnt copy and upgrade to CPC3" window is closed after the import using the "x" in the top right. 

The USB stick must now be removed from the system as described in section 6.3.1. 

Important: The USB stick must only be removed from the WLZent3 after unmounting. 
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Leave the maintenance mode as described in section 8.2 Exiting Maintenance mode.  

The WLZent3 now starts up in read-only mode. When the Wireless Professional software starts, the data imported from the 
WLZent/WLTouch is used and converted to the current format. This can take some time, depending on the amount of data. Once this 
is completed, the WLZent3 takes over the monitoring function of the associated devices. 

Note: It is necessary to reselect the serial interface of the coordinator, as it is named differently on the WLZent3 than in the previous 
system. 

Note: If the coordinator is changed with the WLZent3, it is necessary to carry out a coordinator change according to the Wireless 
Professional manual after the data import so that the wireless connection of the devices to the new coordinator is established correctly. 
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19 Web Browser 

There is a web browser installed on the Wireless Professional WLZent. The web browser is present to allow you to access central battery 
systems with a web server, such as multiControl plus. Instances may arise where the web browser is changed when the WLZent is 
updated. 

19.1 Launching web browser 
The web browser can be launched using the taskbar symbol or by going to “Start menu->Internet->Chromium-Webbrowser”.  

 

Figure 79 Wireless Professional WLZent Start menu Internet 

In this version of the Wireless Professional WLZent, Chromium is installed as the web browser. 

Note: The web browser may take around 10 seconds to launch.  

If assistance is needed when using the web browser, consult the Help menu for the web browser.  
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20 Text editor 

There is a text editor installed on the Wireless Professional WLZent. It can be used to store Wireless Professional logs as plain text.  

20.1 Launching text editor 
The text editor can be launched by going to “Start menu->Accessories->Text Editor”. 

 

 

Figure 80 Launching text editor 

 

20.2 Inserting text 
To insert a text from the clipboard into the editor, the “Strg”/”Ctrl” and “V” buttons are tapped one after another on the on-screen 
keyboard that opens automatically. Once “Strg”/”Ctrl” has been tapped, the button background changes to grey. Alternatively, the 
user can go to Edit->Paste. 
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Figure 81 Text editor 

 

 

Figure 82 Text editor, Edit menu 

20.3  Saving file 
Go to File->Save As to save the document.  
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Figure 83 Text editor, saving file 

Another window then opens, in which the storage location can be selected, and a file name assigned. 

 

 

Figure 84 Text editor, Save dialogue 
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Note: Plain text log files should not be stored in the WLZent file system. These files will be lost in the event of a reboot.  

20.4 Closing program 
To close the program, go to File->Quit. (See Figure 83 Text editor, saving file))  

If the text document has not yet been saved, the program will ask whether it is to be saved or not. 
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21 Firewall 

The Wireless Professional WLZent has a firewall, which blocks incoming and outgoing connections to and from the device provided 
they are not needed for operation. Changes to the firewall configuration are not recommended and are undertaken at the user’s own 
risk.  

Note: Before changing the firewall settings, a manual backup should be performed (see 23.2 Manual backup) because otherwise the 
Wireless Pro database is not transferred to the backup stick and data may be lost. 

Note: There are limitations on using drop-down menus via the WLZent touch display which is why we recommend using the arrow keys 
on the on-screen keyboard to make a selection from a drop-down menu.  
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22 Operating System and Wireless Professional Updates  

The Wireless Professional WLZent regularly checks for updates to the operating system and the Wireless Professional software. The 
WLZent needs an Internet connection for this check. Once a week (Sundays at midnight), the WLZent automatically looks for updates, 
downloads these of its own accord and installs them.  

This update process requires no manual intervention. There is however an option for manually starting the process of looking for and 
installing updates at any time regardless of the weekly pattern described above. To do this, click on the “Search for Updates” command 
in the Start menu. 

Note: Your IT administrator may need to release the update server in the firewall. 

Important: From time to time, the operating system will itself indicate by means of an icon in the bar on the top edge of the screen that 
there is an update available. Click on this to install the update (see image below). However, for technical reasons, an update installed 
in this way will be lost during a system reboot. Updates should NOT therefore generally be performed via the icon, instead ONLY 
use the “Search for Updates” command in the Start menu. 

Note: Instances may arise where individual operating system updates are not installed. If this happens, the Update icon remains in 
place or appears again. This is not a malfunction but is intentional. In such cases, ignore the Update icon. 

 

 

Figure 85 WLZent taskbar: Update Available 

Note: There are no means of updating the operating system offline or reinstalling software on the device, e.g. via a USB stick. 
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23 Backing up Wireless Professional WLZent Data 

23.1 Automatic backup  
Every 4 hours, the Wireless Professional WLZent copies relevant data from the main memory to the backup USB stick fitted in the 
WLZent. This ensures that data is backed up onto an external storage medium. 

Warning: The backup USB stick must not be removed during operation otherwise there is a risk of data loss. 

Note: The backup USB stick and device form one unit. The backup USB stick cannot be changed for another USB stick or replaced. If 
the backup USB stick is lost, a new one must be ordered as a spare part. 

23.2 Manual backup 
Manual backup means that the user triggers the process of copying the relevant data from the main memory to the backup USB stick 
fitted in the WLZent.  

The user can trigger the copying process by rebooting the WLZent (see 9.4.) Alternatively, the copying process can be triggered during 
commissioning, for instance, by going to “Start menu->Other->Instant WLPro Backup”. 

 

Figure 86 WLZent Start menu: Instant WLPro Backup 

Once selected, the “WLPro instant backup” window opens. 
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Figure 87 WLPro instant backup window 

Tapping on the “OK“ button starts the backup process. As soon as the backup is complete, the “WLPro instant backup” window 
contains the text “Backup done”. The window is closed by clicking on the “Exit” button. 

 

Figure 88 WLPro instant backup done 
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23.3 Copying backup files to another device 
The Wireless Professional data can only be copied manually from the backup USB stick fitted in the WLZent.  

22.3.1 Connecting the backup USB stick to the PC 

Warning: The backup USB stick must not be removed during operation otherwise there is a risk of data loss. 

To copy data from the backup USB stick, first shut down the WLZent. Once the device has been shut down and disconnected from the 
power supply, the backup USB stick can be removed. 

The backup USB stick can be read by a computer. The backup USB stick is displayed as “WLPROSAFE” as a drive on the computer. 

 

Figure 89 Backup USB stick on a Windows device 

The drive has a folder structure where the WLZent data is stored. Copying the “backup” folder, copies all the Wireless Professional 
software data. This can then be stored as a backup. 

Once copying is complete, the backup USB stick should be inserted back into the WLZent slot from which it was removed. 

The WLZent should be reconnected to the supply voltage. The WLZent is booted as normal and runs the Wireless Professional software 
for emergency light monitoring.  
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22.3.2 Transfer data from WLZent Backup Stick to an external USB drive  
Minimize the Wireless Professional Software window to get access to the desktop before connecting the USB Stick to the WLZent.  

 

Figure 90 WLZent3 Desktop 

Tap the desktop icon the USB Backup stick drive to open the drive into the file explorer. The drive is named as “WLPROSAFE”. 
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Figure 91 File explorer of the Backup USB-Stick 

Connect the USB Stick to the WLZent now. The “Removable medium is inserted” window will be showed, after the Linux had detected 
the drive. 

 

Figure 92 WLZent removable medium is inserted. 
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Tap the „Ok“ button to open a second file explorer window with the contend of the USB Stick. 

 

Figure 93 WLZent File explorer of an empty USB stick.  

In this example is an empty USB Stick used. Both file explorer windows need to be moved to the right and left side of the screen. 

 

Figure 94 2 file explorer windows with vertical offset.  
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Tap the folder “backup” from WLZent backup USB stick and copy the folder via Drag&Drop to the connected USB stick.  

 

Figure 95 Drag&Drop operation at the backup folder. 

By dropping the folder, the copy progress will be started. 

 

Figure 96 Copy process of the backup folder. 
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Is the copy process is completed, the USB stick need to be unmounted before it can be removed from the WLZent (see 6.3.1 Ejecting 
via taskbar symbol). 

The file explorer window of the “WLPROSAFE” can be closed.  

Note: Before the „backup“ folder contents are copied from the backup USB stick, in the Wireless Professional Software should be 
taped the button “save System”. Also the instant backup (see 23.2 Manual backup) should be performed, to get the current data from 
the Wireless Professional Software into the backup folder. If the version of the Wireless Professional Software is 3.0 or higher the 
instant backup is not necessary anymore.  

23.4 Restore from Backup data 
The restoring of the Wireless Professional Software from backup file may performed only by qualified and authorized personnel.  

Only backup data from this WLZent are allowed to use for a restore process. Backup data from other devices like WLTouch must be 
imported by using the import scrips see chapter 18.2 Import data from WLZentx/WLTouchx. 

Backup files can be only copied to the WLZent in maintenance mode, so first step change to maintenance mode see chapter 8.1 
Launching Maintenance mode  

Tap the desktop icon „WLPROSAFE” to open the file explorer, after the WLZent is booted up in maintenance mode. 

 

Figure 97 file explorer with content of WLPROSAFE. 

Move the explorer window to the right side of the screen, to simplify the drag&drop. 

Put the USB stick with the backup data into the USB connector of the WLZent. The USB stick will be mounted and the “Removable 
medium is inserted” window will popup. Tap the “ok” button to open the file explorer.    
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Figure 98 File explorer: USB stick with backup data.  

In this example there are only one backup folder in the main path of the USB Stick. 

Move the File explorer window via drag&drop to the left until the file explorer window of the “WLPROSAFE” drive is visible.  

 

Figure 99 File explorer windows moved relative to each other. 
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From the left file explorer window move the “backup” folder via Drag&Drop to the file explorer windows in the right side and release 
the folder there. 

 

Figure 100 Drag&Drop of the folder. 
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Release the folder to start the copy process. The “Confirm File Replacing” window will appear.  

 

Figure 101 Confirm Replacing 

Tap the checkbox „Apply this option to all existing files” than tap the button “Overwrite”. 

Remove the connected USB-Stick as described in chapter 6.3.1 Ejecting via taskbar symbol. Remove the USB-Stick once the ejection 
is complete. 

Leave the Maintenance Mode as described in chapter 8.2 Exiting Maintenance mode. 

After the reboot of the WLZent is finished, the Wireless Professional Software is started with the restored backup data. 
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24 Long-Term Backup 

The Wireless Professional WLZent regularly stores a backup copy of the reference data and log files in a special folder on the backup 
USB stick.  

These long-term backups are produced automatically on the 1st and 16th of each month. No more than 24 backups are held in the 
folder for backups. This is the equivalent of 12 months of backups. The oldest backup is then overwritten each time.  

The backups are named in the folder with the date on which they were produced.  

The backups can be used to restore a former status.  
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25 Reinstalling Language Files  

The Wireless Professional software is supplied with various languages pre-installed.  

Additional or more recent language files for the Wireless Professional software will be loaded with the automatic software updates as 
soon as they are available.  
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26 FAQ 

26.1 What devices can be connected to the USB socket? 
Hubs, USB storage media and external input devices, such as a keyboard or mouse. 

26.2 Can additional software be installed on the device? 
Further software can be installed but requires detailed knowledge of Linux. As a rule, only software approved for this purpose by the 
manufacturer may be installed on the device. 

Warning: If third-party software or software not approved by the manufacturer is operated on the WLZent, it will not be covered 
by the warranty. The manufacturer does not assume liability for data loss or damages resulting from malfunction if third-party 

software or software not approved by the manufacturer is operated on the system. What’s more, the manufacturer does not provide 
support of any kind for installing and running third-party software. 

26.3 Are software updates automatically downloaded from the Internet? 
Yes. 

26.4 Is a backup to a network drive possible? 
Yes. A manual backup can also be saved to network drives. 

26.5 Why does the Wireless Professional application keep restarting? 
To ensure continuous monitoring of the self-contained emergency luminaires, the Wireless Professional software must be active at all 
times. The WLZent3 has a so-called WatchDog mechanism, which checks every 30 seconds whether the Wireless Professional 
application is running. If this is not the case, the Wireless Professional software is restarted. 
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27 Revision History 

 

Wireless Professional WLZent – Operating Instructions 

Date Version / Revision Comments/Important changes compared to the previous version 
01/12/2020 1.0 Creation 
07/09/2021 1.1 Change to additional cable entry for fault indication contact 
15/02/2023 1.2 Wireless connection added, text editor added 
29/01/2024 1.3 Change for new OS 
15/08/2024 1.4  
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28 Contact Information 
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